Minimum Requirements for TeamClock (iOS)

Listed here the specifications to be able to download the TeamClock Application.

Device Specification that we support:

  • We only support devices that are compatible with the latest version of Apple’s iOS
  • We require you to be running at least the full numbered version of the current iOS e.g 10.0, 10.1, 10.2 but not 9.7
  • We may require you to upgrade to the very latest version available to troubleshoot problems

  *TeamClock can only run properly on the devices with the latest version of Apple’s iOS as a minimum requirement to operate and receive support.

Terms of Service and Privacy Policy can be found on your PayrollHero account.