Minimum system and device requirements to run My Clock and TeamClock (ALL)

MyClock and TeamClock require that your Computer, iOS or Android devices run the following settings and installs in order for the applications to work correctly.

The minimum operating requirements we support are:

For apple devices:

  • We only support devices that are compatible with the latest version of Apple’s iOS
  • We require you to be running at least the full numbered version of the current iOS e.g 10.0, 10.1, 10.2 but not 9.7
  • We may require you to upgrade to the very latest version available to troubleshoot problems
For Android:
For Windows desktops:
For macOS:
  • We only support the latest version of macOS
For any Desktop:
  • We only support the latest version of Google Chrome
*Note: We currently do not support
  • Linux
  • Windows Phones
  • Windows RT
  • Blackberry
Internet Connection Speed
  • We require a minimum internet connection speed of 2.0 mbps

 

If you experience any problems using the apps or you don’t know how to check if you’re running the minimum operating requirements, please contact us at support.

Tip: If your computer is not running the latest version of the Google Chrome browser, you can get it, here: Download and install the latest version of Google Chrome

 

That concludes this article. You should now know what minimum operating requirements your computer or iOS device needs to run the MyClock and TeamClock Apps. If you have any further questions or experience any issues, contact us at support. We’d be happy to help!